DCS 1.5.2 is now the standard version

As per media release today on the DCS forums:

DCS World 1.5.2 released for main public game version!

Please use DCS Updater to update current DCS 1.2.16 to DCS 1.5.2.

Note. All products (modules) should be installed via ingame Module Manager only. Dedicated installers will not be provided anymore.

 

Please remember to disable all mods prior to updating

Submit a Comment

Your email address will not be published. Required fields are marked *